Bug reports

Posted September 27, 2017 by ilee

If you suspect you found a bug in StarLogo Nova 2.0, please write about it here.  In particular it is useful if you can tell us the following:

- What happened? What didn't work the way you expected?

- Are there steps that led up to it not working?

- Does it happen every time? is it repeatable?

- if possible please provide a link to a PUBLIC project that exhibits this behavior.

Thank you!


Submitted by tbrass on Wed, 09/27/2017 - 20:18 · Permalink


My students and I tried programming the Paintball game with the HTML5 version, and we've found the following:

  • No ability to navigate player (tried different keys - none responding)
  • Browsers are crashing with WebGL errors

We're running Chrome 61.0.3163.100 on Windows 10 PC laptops. I've taught this lesson for several years and haven't seen this behavior. Anyone else? I'll likely have kids go back to the flash version for the remainder of the unit just to get through it. I like many of the new features, but we intro this for game design before kids do simulations in science.

Student works in progress (not complete, but code would still have functioned in the flash version) where I'm seeing these issues:




Submitted by ilee on Wed, 09/27/2017 - 20:39 · Permalink

Thanks for the report.

I'll test the player movement in response to key strokes. 

I saw another person have a WebGL error.  In that case a message of "Rats! WebGL hit a snag!"

Here's a solution: Click Reload. You should check your code to make sure that you're not creating too many agents. Also look for and fix other bugs in your code. You can also try an alternative renderer by adding "?2d=true" to the end of the project URL. For example: http://www.slnova.org/djwendel/projects/496029/?2d=true


Submitted by Wendy Huang on Thu, 09/28/2017 - 10:59 · Permalink

Click on the terrain. Then the keys to control movement will work.

The 2nd project has additional student-generated bugs though. Check the Turtle page.

Submitted by Daniel Wendel on Thu, 09/28/2017 - 11:08 · Permalink

In reply to tbrass:

Re: navigation - this is a small bug with an easy workaround! You need to click on Spaceland (anywhere) to transfer keyboard focus to the game. Then the keys will work. The bug is that if you click on "forever", the key focus moves to that button instead, so it stops working in the game. Luckily, clicking back on Spaceland somewhere will make them work again.

Re: WebGL crashes - this is a combination of factors. Chrome has a WebGL bug that causes crashes on some computers, especially if you use tons and tons of agents. Luckily, clicking "reload" when the error window pops up will fix it (until the next crash, when you can reload again). We did provide an alternate renderer for people whose WebGL isn't working right, but it doesn't have "tweening" currently, so it seems a bit jerky while it runs. You can force this alternate rendering mode by adding "?2d=true" after the project URL. For example, here is my fish test project: http://www.slnova.org/djwendel/projects/496029/?2d=true

Submitted by tbrass on Thu, 09/28/2017 - 12:18 · Permalink

In reply to Wendy Huang:

Clicking on the terrain helped - thanks!

I noticed the issues under Turtle. Once I fixed them in a remix, and clicked on the terrain, it worked.

I think I'll talk to the kids (two sections of 6th graders) and give it another shot. May try Daniel's tip, too.

I'm teaching in a 6th grade computer science class. One of our core themes is FGRTOT (FiGuReiTOuT), so I can use what I'm learning here, with help from this community, as an example.

Thanks, all!

Submitted by tbrass on Wed, 10/11/2017 - 14:06 · Permalink

In reply to Daniel Wendel:

I've had more students come to me (and have seen it on my own machine) when content suddenly won't render in 3d. Example file: http://www.slnova.org/tbrass/projects/500304/

Reload loads it in 2d, which isn't appropriate for a first person game.

Having too many breeds makes sense, but this one only has 227 characters generated, and most are stationary. Rendering in 2d isn't viable.

Will Firefox or Edge handle WebGL more effectively?

Submitted by ilee on Wed, 10/11/2017 - 18:21 · Permalink

Hi Tami,  I think there is some confusion about 2D model.  In 2D mode the StarLogo Nova rendering engine uses snapshots of 3D objects rather than rendering each polygon of a full 3D object, BUT it still approximates 3D.  The game does not go "flat" or anything, it is just a cheaper way to render objects.

Here's a screen shot of how it looks in 2D render mode...  I think it looks okay but I'm not sure what part is/is not working.

snapshot of game

Submitted by Daniel Wendel on Thu, 10/12/2017 - 17:16 · Permalink

Hi Tami,

I think there is something not working quite right on some computers. Yes, different browsers (Firefox in particular) might work better if Chrome is not, but I can't say for sure. It depends on a combination of things like graphics card, operating system, and the complexity of the 3D shapes being used. I hope to have a couple of changes in the next week or two that will improve things for some users, and those might help for your case as well. If not, as Irene said, I think "2D mode" (badly named!) might be fine for now. It uses 2D graphics to do a "fake 3D" that looks pixelated and rough, but it still looks like it is 3D, so a first-person game should be fine. As always, let me know if it doesn't work for you!


Submitted by awyman on Thu, 10/26/2017 - 20:46 · Permalink

In reply to tbrass:

I am having the same issues. My students are working on Catching Flies and using the Chrome browser on Windows 10 machines. The browser crashes frequently with the WebGL error and the students need to reload. The reload doesn't always work on the first try, so they keep reloading. Some just started using Firefox today and it crashed less often. 

I also had an issue where agents were suddenly not showing up on the terrain and the code looked fine. We were able to fix that by changing the color of the agents. 

Submitted by Daniel Wendel on Thu, 10/26/2017 - 23:01 · Permalink

I've been investigating this issue and have found a patch that seems to solve the problem on most computers. I will be testing during the day tomorrow (Friday), and will update the server if all goes well, so hopefully the issue will be solved for you by Monday!

Submitted by Daniel Wendel on Thu, 10/26/2017 - 23:57 · Permalink

If anyone is having crashes and wants to try the new patch, use staging.slnova.org instead of www.slnova.org. It's the same user accounts and projects, but a newer (and less tested!) version of the StarLogo Nova code. It would be super helpful if a few people could try it on a variety of machines to see if this 1) solves the issue for you, 2) delays the crashes but doesn't prevent them entirely, or 3) does nothing. As I said, I'll be doing my own testing during the day Friday as well.

p.s. this version also has fixes for a few issues with procedure blocks and breed renaming, and a new drawer picker with colored background and outlined fonts.

Submitted by tbrass on Fri, 10/27/2017 - 08:42 · Permalink

I gave my kids a choice between the old flash.slnova.org and the new site; most chose the new and, although a number have experienced crashing, it's been a good experience. I've used this opportunity to discuss the software engineering process and mentioned that their feedback is helping make a good tool even better. The SLNova unit is over for this trimester, but it will be great to have this version to start with when my next trimester section starts.

Thanks for all of your work on this. 

Submitted by awyman on Fri, 10/27/2017 - 09:43 · Permalink

In reply to Daniel Wendel:

The staging server is working great! We tested it this morning and what a difference. We had one or two computers freeze and needed to be refreshed, but only once. The machines were fine after one refresh. The changes you made last night made a huge difference! Thanks Daniel.

Submitted by awyman on Wed, 12/06/2017 - 13:42 · Permalink

My students are having issues with scattering the agent who has the camera in their paintball games. When they have scatter in the agent who takes the camera, Spaceland spins around and around. We originally solved this by never scattering the agent who takes the camera which worked fine, but now the students want to create a portal that teleports the the player (in the paintball game) to a random location when the player runs into a portal agent. They programmed a collision with the player and the portal that makes the player scatter once (exactly like the skill card#9 Teleport). When the code runs Spaceland spins around and around. They also programmed the player to teleport to a random x and y with a z of 0. This also caused Spaceland to spin.

Is there a way to fix this in their code or is a bug?

Submitted by tbrass on Wed, 12/06/2017 - 14:02 · Permalink

In reply to awyman:

I had the same issue and never found a solution. When we talked about it, all the kids wanted to make their player spin :-) That lasted about three minutes, until they realized it meant not being able to play the game.

Submitted by Daniel Wendel on Thu, 12/07/2017 - 16:09 · Permalink

In reply to awyman:

Sorry for the slow reply! This is a bug. We've fixed it in our local version, but need to push that change to the server, which I'll do sometime over the next few days. The simple workaround for now is to "take camera" again immediately after the teleport/scatter/whatever movement. That will reset the camera view and stop the spinning.

Submitted by JoeyScott on Thu, 01/04/2018 - 18:05 · Permalink

I am using Killer Whale 2 in my simulation and when it dies, all of them don't immediately disappear. One (the first one) ends up looking like a skeleton. Help?

Skeleton whale

Submitted by Daniel Wendel on Tue, 01/09/2018 - 17:07 · Permalink

In reply to JoeyScott:

Hi JoeyScott, thanks for the report! This is a graphics (rendering engine) glitch caused by a bug in the way we handle high-performance rendering. When the number of agents with a particular shape goes from non-zero back to zero, a "skeleton" (basically corrupted graphics memory!) remains behind.

This is actually a deep problem that requires a substantial re-write of the graphics engine to fix! I am working on it now, but it will probably take at least a few weeks, and likely a month or two. There isn't a great workaround for it, but if it's really getting in the way, you can make all agents really tiny before you delete them. That will at least make the skeletons really small =P.

I will update the StarLogo Nova homepage once this issue is fixed, and will also hopefully post a note here as well!

Submitted by JoeyScott on Fri, 01/12/2018 - 11:09 · Permalink

Thanks, Daniel -- that is helpful.